[Corrigé 3.2.7] problème authentification LDAP

Vous avez trouvé un bug dans l'application (dernière version stable ou bêta): Décrivez le ici afin que la correction soit intégrée a la prochaine version.
Avatar du membre
Flox
Administrateur du site
Messages : 6499
Enregistré le : jeu. 21 juin 2012 19:00

Re: problème authentification LDAP

Message par Flox »

Pouvez-vous indiquer sur la fiche LDAP de l'utilisateur jmaton, quel est l'attribut utilisé pour le champ login de GestSup ?
GestSup: 3.2.17 | Debian: 11 | Apache: 2.4.51 MariaDB: 10.6.5| PHP: 8.0.12
Avatar du membre
Flox
Administrateur du site
Messages : 6499
Enregistré le : jeu. 21 juin 2012 19:00

Re: problème authentification LDAP

Message par Flox »

Pourrez-vous également tester ce nouveau patch ?
Fichiers joints
patch_pour_3.2.4.zip
(4.84 Kio) Téléchargé 97 fois
GestSup: 3.2.17 | Debian: 11 | Apache: 2.4.51 MariaDB: 10.6.5| PHP: 8.0.12
jmaton
Gsup LEVEL 1
Messages : 12
Enregistré le : mer. 2 déc. 2020 11:39

Re: problème authentification LDAP

Message par jmaton »

Super ça fonctionne avec ce patch !
Merci !
Je vais pouvoir continuer mes tests.
Cordialement.
Gestsup : 3.2.4 (3.2 patch 4) / Apache : 2.4 / MariaDB : 10.5.5 / PHP : 7.4.10
Avatar du membre
Flox
Administrateur du site
Messages : 6499
Enregistré le : jeu. 21 juin 2012 19:00

Re: problème authentification LDAP

Message par Flox »

Très bien merci pour retour.
GestSup: 3.2.17 | Debian: 11 | Apache: 2.4.51 MariaDB: 10.6.5| PHP: 8.0.12
webmaster_prevor
Gsup LEVEL 0
Messages : 9
Enregistré le : ven. 15 oct. 2021 11:25

Re: [Corrigé 3.2.7] problème authentification LDAP

Message par webmaster_prevor »

Bonjour,

Je me permets de rouvrir ce sujet car je rencontre ce même problème alors que j'ai installé la dernière version en date de GestSup, soit la 3.2.15 (Version 3.2 avec patch 15).

J'ai même installé le patch "patch_pour_3.2.4.zip" mais cela ne change rien.

Lorsque je tente de me connecter avec un compte LDAP, Apache2 me retourne l'erreur suivante :

AH01071: Got error 'PHP message: PHP Warning: ldap_search(): Search: Can't contact LDAP server in /var/www/vhosts/my-gestsup.net/httpdocs/login.php on line 173PHP message: PHP Warning: ldap_first_entry() expects parameter 2 to be resource, bool given in /var/www/vhosts/my-gestsup.net/httpdocs/login.php on line 175', referer: https://supportbat.prevor.com/index.php

Cordialement.
Avatar du membre
Flox
Administrateur du site
Messages : 6499
Enregistré le : jeu. 21 juin 2012 19:00

Re: [Corrigé 3.2.7] problème authentification LDAP

Message par Flox »

Bonjour,

Merci de déclarer un nouveau sujet avec un impression écran de votre page système.

Cdt
GestSup: 3.2.17 | Debian: 11 | Apache: 2.4.51 MariaDB: 10.6.5| PHP: 8.0.12
Répondre