Problème de Maj Auto

Installation & Configuration du logiciel
tatien
Gsup LEVEL 1
Messages : 12
Enregistré le : jeu. 22 janv. 2015 10:48

Problème de Maj Auto

Message par tatien »

Bonjour, et merci encore pour votre super boulot,

- Nous sommes en version 3.2.3, nous voudrions passer en dernière version.

- D'habitude nous utilisons le menu Mise à jour dans l'administration pour passer tous les patchs 1 par un. En faisant "vérifier" il nous détecte automatiquement le patch suivant, puis on le "télécharge" puis "mise à jour semi automatique", et tout se passe impeccable.

- Mais hier j'ai voulu rattraper notre retard de patch, et lorsque clique sur le bouton "verifier" il nous dit :

Installation impossible votre version est à jour

Version actuelle 3.2.3 (Version 3.2 avec patch 3)
Canal

Stable
Serveur de mise à jour Serveur de mises à jour ftp.gestsup.fr est disponible.



Y a t'il une autre solution que de passer les patchs à la main ?

Bien cordialement
Avatar du membre
Flox
Administrateur du site
Messages : 6499
Enregistré le : jeu. 21 juin 2012 19:00

Re: Problème de Maj Auto

Message par Flox »

Bonjour,

pouvez-vous transmettre un impression écran de la page Administration > Système ?

J'ai réalisé un test de mon côté et ne reproduis pas votre soucis :
2021-07-30 11_17_34_screenshot_gestsup.png
2021-07-30 11_17_34_screenshot_gestsup.png (14.13 Kio) Vu 503 fois
2021-07-30 11_18_02_screenshot_gestsup.png
2021-07-30 11_18_02_screenshot_gestsup.png (44.01 Kio) Vu 503 fois

Pour information les procédures de mises à jour :
https://doc.gestsup.fr/update/

Cdt
GestSup: 3.2.17 | Debian: 11 | Apache: 2.4.51 MariaDB: 10.6.5| PHP: 8.0.12
tatien
Gsup LEVEL 1
Messages : 12
Enregistré le : jeu. 22 janv. 2015 10:48

Re: Problème de Maj Auto

Message par tatien »

Image
Avatar du membre
Flox
Administrateur du site
Messages : 6499
Enregistré le : jeu. 21 juin 2012 19:00

Re: Problème de Maj Auto

Message par Flox »

Pourrez-vous vérifier vos firewalls les désactiver temporairement pour faire un test, et transmettre une impression écran de la page affiché après avoir appuyé sur le bouton "Vérifier MAJ".

Transmettre également la version affiché dans l'entete du fichier /core/update.php

Cdt
GestSup: 3.2.17 | Debian: 11 | Apache: 2.4.51 MariaDB: 10.6.5| PHP: 8.0.12
tatien
Gsup LEVEL 1
Messages : 12
Enregistré le : jeu. 22 janv. 2015 10:48

Re: Problème de Maj Auto

Message par tatien »

Bonjour Flox et merci pour votre réponse.

je ne trouve pas de fichier update.php dans le répertoire Core.

Image
tatien
Gsup LEVEL 1
Messages : 12
Enregistré le : jeu. 22 janv. 2015 10:48

Re: Problème de Maj Auto

Message par tatien »

Le firewall du serveur est désactivé. Et quand je clique sur le bouton VERIFIER, il y a cette image :

Image

Cdt
Avatar du membre
Flox
Administrateur du site
Messages : 6499
Enregistré le : jeu. 21 juin 2012 19:00

Re: Problème de Maj Auto

Message par Flox »

Le fichier est /admin/update.php
GestSup: 3.2.17 | Debian: 11 | Apache: 2.4.51 MariaDB: 10.6.5| PHP: 8.0.12
tatien
Gsup LEVEL 1
Messages : 12
Enregistré le : jeu. 22 janv. 2015 10:48

Re: Problème de Maj Auto

Message par tatien »

<?php
################################################################################
# @Name : update.php
# @Description : page to update GestSup
# @Call : admin.php
# @Parameters :
# @Author : Flox
# @Create : 20/01/2011
# @Update : 11/06/2020
# @Version : 3.2.2
################################################################################
tatien
Gsup LEVEL 1
Messages : 12
Enregistré le : jeu. 22 janv. 2015 10:48

Re: Problème de Maj Auto

Message par tatien »

Mise à jour de GestSup
Votre version 3.2.3 est à jour, pas de téléchargement nécessaire

Version actuelle 3.2.3 (Version 3.2 avec patch 3)
Canal

Stable
Serveur de mise à jour Serveur de mises à jour ftp.gestsup.fr est disponible.



Nous avons fait un sorte que le serveur ne passe plus par le firewall materiel de chez nous, et les patchs supérieurs dispos ne sont toujours pas détectés. Ce n'est donc pas un soucis de parfeu :cry:
Avatar du membre
Flox
Administrateur du site
Messages : 6499
Enregistré le : jeu. 21 juin 2012 19:00

Re: Problème de Maj Auto

Message par Flox »

Bonjour,

Vous pourrez installer les maj de manière manuelle cf docs
GestSup: 3.2.17 | Debian: 11 | Apache: 2.4.51 MariaDB: 10.6.5| PHP: 8.0.12
Répondre