[Corrigé 3.2.12] Impossible de valider la page connecteurs

Vous avez trouvé un bug dans l'application (dernière version stable ou bêta): Décrivez le ici afin que la correction soit intégrée a la prochaine version.
Avatar du membre
Flox
Administrateur du site
Messages : 6453
Enregistré le : jeu. 21 juin 2012 19:00

Re: Impossible de valider la page connecteurs

Message par Flox »

Merci de me transmettre un fichier zip avec l'ensemble des fichiers et de la base de données, car je ne reproduis pas le problème de mon côté.
GestSup: 3.2.16 | Debian: 11 | Apache: 2.4.51 MariaDB: 10.6.4| PHP: 8.0.12
bfalsata
Gsup LEVEL 1
Messages : 23
Enregistré le : mer. 21 avr. 2021 09:53

Re: Impossible de valider la page connecteurs

Message par bfalsata »

Le fichier étant trop lourd le l'ai envoyé sur wetransfert, vous pouvez le récupérer à l'adresse
Avatar du membre
Flox
Administrateur du site
Messages : 6453
Enregistré le : jeu. 21 juin 2012 19:00

Re: Impossible de valider la page connecteurs

Message par Flox »

J'ai bien récupéré le fichier et ne reproduis toujours pas le problème pouvez-vous tester avec un autre navigateur
Fichiers joints
2021-05-18 14_47_04_screenshot_gestsup.png
2021-05-18 14_47_04_screenshot_gestsup.png (43.06 Kio) Vu 1985 fois
GestSup: 3.2.16 | Debian: 11 | Apache: 2.4.51 MariaDB: 10.6.4| PHP: 8.0.12
bfalsata
Gsup LEVEL 1
Messages : 23
Enregistré le : mer. 21 avr. 2021 09:53

Re: Impossible de valider la page connecteurs

Message par bfalsata »

Je pense avoir trouvé le problème. Et c'est bien dans le fichier :

Code : Tout sélectionner

/parameters/connector.php
ligne 673
include('plugin.php');

avec cette instruction c'est le fichier :
admin/parameters/plugin.php qui est inclus

et je pense que c'est le fichier plugin.php situé à la racine qui devrait l'être
Si je remplace l'instruction par
include('plugin.php');
par
include('../../plugin.php');

ça marche nickel
Avatar du membre
Flox
Administrateur du site
Messages : 6453
Enregistré le : jeu. 21 juin 2012 19:00

Re: Impossible de valider la page connecteurs

Message par Flox »

Il s'agit effectivement bien du fichier qui est à la racine qu'il faut appeler à ce niveau.
Ce qui est étrange c'est que le bon fichier est appelé de mon côté.

pourrez-vous tester avec cette valeur, dans /parameters/connector.php :

Code : Tout sélectionner

 include('./plugin.php');
GestSup: 3.2.16 | Debian: 11 | Apache: 2.4.51 MariaDB: 10.6.4| PHP: 8.0.12
bfalsata
Gsup LEVEL 1
Messages : 23
Enregistré le : mer. 21 avr. 2021 09:53

Re: Impossible de valider la page connecteurs

Message par bfalsata »

Oui ça marche avec
include('./plugin.php');
Avatar du membre
Flox
Administrateur du site
Messages : 6453
Enregistré le : jeu. 21 juin 2012 19:00

Re: Impossible de valider la page connecteurs

Message par Flox »

Très bien, la prochaine version intégrera cette correction.
GestSup: 3.2.16 | Debian: 11 | Apache: 2.4.51 MariaDB: 10.6.4| PHP: 8.0.12
bfalsata
Gsup LEVEL 1
Messages : 23
Enregistré le : mer. 21 avr. 2021 09:53

Re: [Corrigé 3.2.12] Impossible de valider la page connecteurs

Message par bfalsata »

Ok, merci, bonne continuation
Répondre