[Corrigé 3.2.12] Impossible de valider la page connecteurs

Vous avez trouvé un bug dans l'application (dernière version stable ou bêta): Décrivez le ici afin que la correction soit intégrée a la prochaine version.
bfalsata
Gsup LEVEL 1
Messages : 23
Enregistré le : mer. 21 avr. 2021 09:53

[Corrigé 3.2.12] Impossible de valider la page connecteurs

Message par bfalsata »

Impossible de faire des modifications sur la page administration > paramètres > connecteurs

Je me retrouve avec 2 boutons "Valider" (cf : PJ) mais aucun des deux ne fonctionnent.
J'ai ce problème depuis le passage en 3.2.9.
J'ai testé avec la version 3.2.10 et 3.2.11 et le problème est là également.
Fichiers joints
connector.png
connector.png (139.42 Kio) Vu 1418 fois
Avatar du membre
Flox
Administrateur du site
Messages : 6367
Enregistré le : jeu. 21 juin 2012 19:00

Re: Impossible de valider la page connecteurs

Message par Flox »

Bonjour,

pouvez-vous transmettre un impression écran de votre page système ?
Pourrez-vous indiquer comment reproduire le problème sur la webdemo ?

Cdt
GestSup: 3.2.15 | Debian: 11 | Apache: 2.4.49 MariaDB: 10.6.4| PHP: 8.0.11
bfalsata
Gsup LEVEL 1
Messages : 23
Enregistré le : mer. 21 avr. 2021 09:53

Re: Impossible de valider la page connecteurs

Message par bfalsata »

Pour info, j'utilise Xampp 3.3.0
Pour être sur j'ai refait une installation complète en partant de GestSup 3.2.5 puis j'ai fait les MAJ une par une jusqu'à la version 3.2.11.
Ce problème apparait à partir de la MAJ vers 3.2.9
Fichiers joints
system.png
system.png (201.17 Kio) Vu 1413 fois
Avatar du membre
Flox
Administrateur du site
Messages : 6367
Enregistré le : jeu. 21 juin 2012 19:00

Re: Impossible de valider la page connecteurs

Message par Flox »

Pouvez vous détailler la méthode utilisée pour l'installation des mises à jours.

Cdt
GestSup: 3.2.15 | Debian: 11 | Apache: 2.4.49 MariaDB: 10.6.4| PHP: 8.0.11
bfalsata
Gsup LEVEL 1
Messages : 23
Enregistré le : mer. 21 avr. 2021 09:53

Re: Impossible de valider la page connecteurs

Message par bfalsata »

Je viens de voir que dans le fichier admin/parameters/connector.php ligne 673 il y avait include('plugin.php');
du coup quand je commente cette ligne le 2ème bouton disparait et le formulaire fonctionne normalement.
Fichiers joints
code.png
code.png (49.14 Kio) Vu 1406 fois
Modifié en dernier par bfalsata le mar. 18 mai 2021 13:31, modifié 1 fois.
Avatar du membre
Flox
Administrateur du site
Messages : 6367
Enregistré le : jeu. 21 juin 2012 19:00

Re: Impossible de valider la page connecteurs

Message par Flox »

J'ai refais une installation depuis la version 3.2.5 jusqu'en 3.2.9 sans observer de problème.

Vous pourrez tester depuis une version 3.2.9 de supprimer le repertoire plugins de votre serveur puis de télécharger le fichier en pièce jointe.

Cdt
Fichiers joints
2021-05-18 13_32_05_screenshot_gestsup.png
2021-05-18 13_32_05_screenshot_gestsup.png (79.59 Kio) Vu 1405 fois
plugins.rar
(27.67 Kio) Téléchargé 40 fois
GestSup: 3.2.15 | Debian: 11 | Apache: 2.4.49 MariaDB: 10.6.4| PHP: 8.0.11
bfalsata
Gsup LEVEL 1
Messages : 23
Enregistré le : mer. 21 avr. 2021 09:53

Re: Impossible de valider la page connecteurs

Message par bfalsata »

J'ai bien remplacé le dossier "plugin" que vous m'avez envoyé et j'ai toujours le même bug.
En inspectant le code HTML on voit que j'ai le bouton "submit_plugin" et "submit_connector"
Fichiers joints
html.png
html.png (165.48 Kio) Vu 1402 fois
bfalsata
Gsup LEVEL 1
Messages : 23
Enregistré le : mer. 21 avr. 2021 09:53

Re: Impossible de valider la page connecteurs

Message par bfalsata »

Est ce que c'est normal d'avoir :
include('plugin.php');

ligne 673 du fichier admin/parameters/connector.php

car quand je commente cette ligne je n'ai plus le problème
Avatar du membre
Flox
Administrateur du site
Messages : 6367
Enregistré le : jeu. 21 juin 2012 19:00

Re: Impossible de valider la page connecteurs

Message par Flox »

Merci d'indiquer la version présente dans l'entête du fichier /admin/parameters.php

et transmettre l'URL affichée sur page des connecteurs
GestSup: 3.2.15 | Debian: 11 | Apache: 2.4.49 MariaDB: 10.6.4| PHP: 8.0.11
bfalsata
Gsup LEVEL 1
Messages : 23
Enregistré le : mer. 21 avr. 2021 09:53

Re: Impossible de valider la page connecteurs

Message par bfalsata »

Entête du fichier :
################################################################################
# @Name : parameters.php
# @Description : admin parameters
# @Call : /admin.php
# @Parameters :
# @Author : Flox
# @Create : 12/01/2011
# @Update : 11/02/2021
# @Version : 3.2.9
################################################################################

URL :
http://support2.rsid.fr/index.php?page= ... =connector
Répondre