Impossible de faire la mise à jour - GestSup me dit que je suis à jour

Installation & Configuration du logiciel
Avatar du membre
bbc94
Gsup LEVEL 3
Messages : 77
Enregistré le : ven. 6 juil. 2018 12:47

Re: Impossible de faire la mise à jour - GestSup me dit que je suis à jour

Message par bbc94 » lun. 10 juin 2019 14:03

Bonjour,

Ayant toujours le même problème malgré mes recherches et plusieurs tentatives, voici ma page système actuelle.

Si je vais dans mise à jour, j'ai :
Version actuelle: 3.1.40 (Version 3.1 avec patch 40)
Canal Beta
Serveur de mise à jour ftp.gestsup.fr est disponible.

=> Quand je fait vérifier cela ne fait rien ...

Le mode debug me dit toujours :

DEBUG MODE:
[CHANNEL] beta
[GET DATA] Local server version: 3.1.40 (Version: 3.1 Patch: 40)

Warning: preg_grep() expects parameter 2 to be array, boolean given in C:\wamp64\www\xxxxxxxxxxxx.group\admin\update.php on line 142

Warning: Invalid argument supplied for foreach() in C:\wamp64\www\xxxxxxxxxxxx.group\admin\update.php on line 144
[GET DATA] No patch available for version 3.1

Warning: preg_grep() expects parameter 2 to be array, boolean given in C:\wamp64\www\xxxxxxxxxxxx.group\admin\update.php on line 160

Warning: Invalid argument supplied for foreach() in C:\wamp64\www\xxxxxxxxxxxx.group\admin\update.php on line 162
[GET DATA] Last version available on FTP server: ..
[COMPARE VERSIONS] Local server version 3.1 is superior than FTP server GestSup ., you are maybe a developper.
Fichiers joints
2019-06-10_135732.png
2019-06-10_135732.png (122.36 Kio) Vu 36 fois
- GestSup 3.1.41 - OS: Windows 2016 64bits - Apache: 2.4.27 - PHP: 7.1.9 - MariaDB - MySQL 5.7.19

Avatar du membre
Flox
Administrateur du site
Messages : 4077
Enregistré le : jeu. 21 juin 2012 19:00

Re: Impossible de faire la mise à jour - GestSup me dit que je suis à jour

Message par Flox » lun. 10 juin 2019 15:24

Bonjour,

Je vous invite a consulter les logs de votre firewall il semble que l'application n'arrive pas a lister le contenu du FTP distant.

Cdt
GestSup: 3.1.41 | Debian: 9.9 | Apache: 2.4.39 | MariaDB: 10.3.15 | PHP: 7.3.6

Répondre