[Corrigé 3.2.11] connexion SMTP

Vous avez trouvé un bug dans l'application (dernière version stable ou bêta): Décrivez le ici afin que la correction soit intégrée a la prochaine version.
Avatar du membre
Flox
Administrateur du site
Messages : 6249
Enregistré le : jeu. 21 juin 2012 19:00

Re: connexion SMTP

Message par Flox »

N'avez vous pas d'adresse mail chez OVH pour l'émission, en renseignant le serveur ssl0.ovh.net
GestSup: 3.2.14 | Debian: 10.10 | Apache: 2.4.48 MariaDB: 10.6.4| PHP: 8.0.8
jf.boutouyrie
Gsup LEVEL 2
Messages : 46
Enregistré le : jeu. 11 janv. 2018 20:49

Re: connexion SMTP

Message par jf.boutouyrie »

C'est ce que je suis en train de créer.
ca change un peu mon flux mais ça devrait passer.
GestSup: 3.2.10 | OVH mutualisé| Mysql: 5.6.50 | PHP: 7.4.15
Avatar du membre
Flox
Administrateur du site
Messages : 6249
Enregistré le : jeu. 21 juin 2012 19:00

Re: connexion SMTP

Message par Flox »

La classe issendmail est normalement faite pour ce genre de cas étrange que cela ne fonctionne pas. Je ne peux réaliser de tests de mon côté n'ayant pas ce type d'hébergement.
GestSup: 3.2.14 | Debian: 10.10 | Apache: 2.4.48 MariaDB: 10.6.4| PHP: 8.0.8
jf.boutouyrie
Gsup LEVEL 2
Messages : 46
Enregistré le : jeu. 11 janv. 2018 20:49

Re: connexion SMTP

Message par jf.boutouyrie »

On pourrait essayer le phpmailer de la 3.2.8?
Car avant j'utiliser cette classe effectivement.
GestSup: 3.2.10 | OVH mutualisé| Mysql: 5.6.50 | PHP: 7.4.15
Avatar du membre
Flox
Administrateur du site
Messages : 6249
Enregistré le : jeu. 21 juin 2012 19:00

Re: connexion SMTP

Message par Flox »

Vous pourrez retrouver les anciennes versions de phpmailer sur github, et remplacer les fichiers dans le répertoire components.
GestSup: 3.2.14 | Debian: 10.10 | Apache: 2.4.48 MariaDB: 10.6.4| PHP: 8.0.8
jf.boutouyrie
Gsup LEVEL 2
Messages : 46
Enregistré le : jeu. 11 janv. 2018 20:49

Re: connexion SMTP

Message par jf.boutouyrie »

Ca se complique.
J'ai remis ma config d'origine office365 avec issendmail.
Je viens de clôturer un ticket, ça à envoyé le mail de clôture, surprise.
Du coup j'essaie de réouvrir ou de faire un envoie de mail depuis le ticket, pas d'erreur à l'envoie mais pas de réception.
Le test du connecteur donne toujours la même erreur par contre.
J'ai refait une autre clôture sur un autre ticket sans succès.
GestSup: 3.2.10 | OVH mutualisé| Mysql: 5.6.50 | PHP: 7.4.15
Avatar du membre
Flox
Administrateur du site
Messages : 6249
Enregistré le : jeu. 21 juin 2012 19:00

Re: connexion SMTP

Message par Flox »

Pouvez-vous essayer de re-télécharger manuellement le patch 3.2.10 depuis la section téléchargement puis écraser les fichiers sur votre serveur.
GestSup: 3.2.14 | Debian: 10.10 | Apache: 2.4.48 MariaDB: 10.6.4| PHP: 8.0.8
jf.boutouyrie
Gsup LEVEL 2
Messages : 46
Enregistré le : jeu. 11 janv. 2018 20:49

Re: connexion SMTP

Message par jf.boutouyrie »

J'ai copié tout les fichiers refais tout les flux et tout est ok.
Mail nouveau ticket
Mail attrib
Mail modif
Mail info de modif
Mail clôture

Je n'ai juste pas cliqué sur le test connecteur car j'ai l'impression que c'est à partir de la ou ca stop. Mais c'est juste une impression.
GestSup: 3.2.10 | OVH mutualisé| Mysql: 5.6.50 | PHP: 7.4.15
Avatar du membre
Flox
Administrateur du site
Messages : 6249
Enregistré le : jeu. 21 juin 2012 19:00

Re: connexion SMTP

Message par Flox »

Ha bonne nouvelle, normalement il n'y a pas d'incidence avec le bouton de test.
GestSup: 3.2.14 | Debian: 10.10 | Apache: 2.4.48 MariaDB: 10.6.4| PHP: 8.0.8
atobo55
Gsup LEVEL 0
Messages : 4
Enregistré le : ven. 30 avr. 2021 20:52

Re: [Corrigé 3.2.11] connexion SMTP

Message par atobo55 »

bonjour,

Je suis en 3.2.8 stable en hébergement mutualisé chez OVH et j'ai rencontré également un soucis d'envoi des notifications par emails. Le 27 avril, tout fonctionnait correctement (un ticket a été traité avec notifications) et le 29 avril, d'autres tickets sont arrivés et aucune notif n'a été envoyée par gestsup ; entre deux, aucun élément de configuration n'a été modifié (au niveau gestsup) ... il semble donc que quelquechose ait changé chez OVH.
En relisant le fil de discussion, et en branche "stable" quel correctif puis-je appliquer pour retrouver les notifications fonctionnelles sur gestsup ?
(avant l'incident, j'étais configuré - depuis des mois - en ssl, sur le port 465 avec une authentification user/mot de passe)

D'avance merci,
Fichiers joints
Screenshot_2021-04-30 GestSup Gestion de Support.png
Screenshot_2021-04-30 GestSup Gestion de Support.png (265.1 Kio) Vu 661 fois
Répondre