[Corrigé 3.1.40] Erreur requête api

Vous avez trouvé un bug dans l'application (dernière version stable ou bêta): Décrivez le ici afin que la correction soit intégrée a la prochaine version.
Répondre
Avatar du membre
dumpau62
Gsup LEVEL 4
Messages : 114
Enregistré le : ven. 15 sept. 2017 15:14
Contact :

[Corrigé 3.1.40] Erreur requête api

Message par dumpau62 »

Bonjour,

Je viens de mettre à jour GestSup en version 3.1.39 avec la nouvelle version de l'API (1.8). Je rencontre une erreur PDO :

Fatal error: Uncaught PDOException: SQLSTATE[HY093]: Invalid parameter number: number of bound variables does not match number of tokens in C:\xampp\htdocs\gestsup\gestsup_api.php:49 Stack trace: #0 C:\xampp\htdocs\gestsup\gestsup_api.php(49): PDOStatement->execute(Array) #1 C:\xampp\htdocs\gestsup\demande_rapide.php(28): include('C:\\xampp\\htdocs...') #2 {main} thrown in C:\xampp\htdocs\gestsup\gestsup_api.php on line 49

La base de donnée, l'utilisateur et le mot de passe est bien renseigné dans le fichier "gestsup_api.php".
J'ai autorisé la connexion SQL sur le serveur.

Quelqu'un pourrait me renseigner sur cette erreur ?

Merci bien
GestSup: 3.1.49 | Debian: 10.2 | MariaDB: 10.3.22 | PHP: 7.3.14

Avatar du membre
Flox
Administrateur du site
Messages : 4865
Enregistré le : jeu. 21 juin 2012 19:00

Re: Erreur PDO SQL

Message par Flox »

Bonjour,

pouvez vous essayer avec cette version ?
Fichiers joints
gestsup_api.zip
(1.53 Kio) Téléchargé 104 fois
GestSup: 3.2.1 | Debian: 10.4 | Apache: 2.4.43 | MariaDB: 10.5.4| PHP: 7.4.7

Avatar du membre
dumpau62
Gsup LEVEL 4
Messages : 114
Enregistré le : ven. 15 sept. 2017 15:14
Contact :

Re: Erreur PDO SQL

Message par dumpau62 »

Ça fonctionne !

Une erreur dans le code source ?
GestSup: 3.1.49 | Debian: 10.2 | MariaDB: 10.3.22 | PHP: 7.3.14

Avatar du membre
Flox
Administrateur du site
Messages : 4865
Enregistré le : jeu. 21 juin 2012 19:00

Re: Erreur PDO SQL

Message par Flox »

Une erreur était présente sur une requête
GestSup: 3.2.1 | Debian: 10.4 | Apache: 2.4.43 | MariaDB: 10.5.4| PHP: 7.4.7

Répondre