[Corrigé 3.2.16] Service du demandeur erroné

Vous avez trouvé un bug dans l'application (dernière version stable ou bêta): Décrivez le ici afin que la correction soit intégrée a la prochaine version.
sandrine
Gsup LEVEL 1
Messages : 15
Enregistré le : lun. 26 juil. 2021 14:24
Contact :

Re: Service du demandeur erroné

Message par sandrine »

Bonjour,

Merci pour votre correctif, mais malheureusement le bug n'est pas corrigé.
Maintenant le service du demandeur reste a "Aucun" dans la liste des tickets et dans le ticket lui même ( Voir capture )

Test réalisé sur mon environnement de test et sur votre webdemo:
  • Cache vider
  • Affectation de user julien au service compta
  • Affectation de John Admin au service informatique
  • Ajout dans les droits de l'affichage de la colonne du service du demandeur
  • Ajout dans les droits de l'affichage du champ service du demandeur dans le ticket
  • Création du ticket n°6 par John Admin pour voir quel service du demandeur apparait
BugServiceDemandeur5.png
BugServiceDemandeur5.png (24.72 Kio) Vu 58 fois
BugServiceDemandeur6.png
BugServiceDemandeur6.png (15.34 Kio) Vu 58 fois
Cordialement
Sandrine
OS : Windows NT, LDAP : Active Directory ,Apache : 2.4.39 , MySQL : 8.0.19, PHP : 7.3.1, GestSup : 3.2.13
Avatar du membre
Flox
Administrateur du site
Messages : 6351
Enregistré le : jeu. 21 juin 2012 19:00

Re: Service du demandeur erroné

Message par Flox »

Bonjour,

je ne reproduis pas le défaut de mon côté sur la webdemo :
2021-09-14 10_44_07_screenshot_gestsup.png
2021-09-14 10_44_07_screenshot_gestsup.png (16.8 Kio) Vu 56 fois

> Pouvez-vous essayer avec un autre navigateur web, Chrome ou Firefox ou Brave ou Edge chromium ?

Si le problème persiste ouvrez la webdemo avec chrome puis appuyer sur la touche F12 dans l'onglet network cliquer sur "Disable cache" puis ré-essayer.

Cdt
GestSup: 3.2.15 | Debian: 11 | Apache: 2.4.49 MariaDB: 10.6.4| PHP: 8.0.10
sandrine
Gsup LEVEL 1
Messages : 15
Enregistré le : lun. 26 juil. 2021 14:24
Contact :

Re: Service du demandeur erroné

Message par sandrine »

Bonjour,

Nos utilisateurs utilisent principalement Firefox.
Nos techniciens utilisent principalement Chrome.
  • Test effectué avec:
    • Firefox (Version 92.0 64bits)
    • Edge (Version 93.0.961.47 (Version officielle) (64 bits))
    • IE11( Dans le doute on y crois encore :lol: )
    • Chrome (Version 93.0.4577.63 (Build officiel) (64 bits))
Resultat:
[OK] Webdemo : le bon service apparait
[KO] Environnement de test : le service demandeur reste à "aucun"
  • Test supplémentaires effectués avec Chrome
    • avec "Disable cache"
    • Actualisation forcée ( Capture )
BugServiceDemandeur7.png
BugServiceDemandeur7.png (6.51 Kio) Vu 53 fois
Resultat:
[OK] Webdemo : le bon service apparait
[KO] Environnement de test : le service demandeur reste à "aucun"

La webdemo fonctionnant, demain je vais faire un RAZ de mon environnement de Test et réinstaller le patch.
OS : Windows NT, LDAP : Active Directory ,Apache : 2.4.39 , MySQL : 8.0.19, PHP : 7.3.1, GestSup : 3.2.13
Avatar du membre
Flox
Administrateur du site
Messages : 6351
Enregistré le : jeu. 21 juin 2012 19:00

Re: Service du demandeur erroné

Message par Flox »

Vous pourrez également vérifier les logs d'erreur Apache afin de détecter une anomalie sur votre environnement.
GestSup: 3.2.15 | Debian: 11 | Apache: 2.4.49 MariaDB: 10.6.4| PHP: 8.0.10
sandrine
Gsup LEVEL 1
Messages : 15
Enregistré le : lun. 26 juil. 2021 14:24
Contact :

Re: Service du demandeur erroné

Message par sandrine »

Bonjour,

Désolée mes tests ont pris plus de temps que prévu sur mon environnement de test
  • Réinstallation d'une version 3.2.12 ( a partir des sauvegardes faite avant la montée de version 3.2.13)
  • Montée de version 3.2.13
  • Installation du patch fournit dans ce sujet
Résultat:
[OK] Environnement de test : le service demandeur a la bonne valeur

Le problème venait surement de mon environnement de test.
Le patch fonctionne

NB: Une idée d'amélioration possible: dans la page mise à jour, prévoir un bouton "Revenir à la version précédente" qui demanderait le chemin de la sauvegarde et qui la remettrait en place ( Oui parfois je suis un peu fainéante :D :D :D )

Merci beaucoup
Bonne journée,
Sandrine
OS : Windows NT, LDAP : Active Directory ,Apache : 2.4.39 , MySQL : 8.0.19, PHP : 7.3.1, GestSup : 3.2.13
Avatar du membre
Flox
Administrateur du site
Messages : 6351
Enregistré le : jeu. 21 juin 2012 19:00

Re: Service du demandeur erroné

Message par Flox »

Bonjour,

Très bien merci pour votre retour.

Cdt
GestSup: 3.2.15 | Debian: 11 | Apache: 2.4.49 MariaDB: 10.6.4| PHP: 8.0.10
Répondre