[Corrigé 3.1.37] Problème envoie de mail sondage

Vous avez trouvé un bug dans l'application (stable ou bêta): Décrivez le ici afin que la correction soit intégrée a la prochaine version.
Répondre
Avatar du membre
dumpau62
Gsup LEVEL 3
Messages : 91
Enregistré le : ven. 15 sept. 2017 15:14

[Corrigé 3.1.37] Problème envoie de mail sondage

Message par dumpau62 » lun. 3 déc. 2018 10:16

Bonjour,

J'ai installé la version 3.1.35 et j'ai remarqué que le mail pour le sondage ne s'envoie pas.
Habituellement, lorsque je clôture un ticket, le mail part directement à l'utilisateur.

Pourriez-vous me dire d'où vient le problème?

Merci

Cdlt
GestSup: 3.1.35 | Ubuntu: 18.04.1 LTS| MySQL: 5.7.24 | PHP: 7.2.10

Avatar du membre
dumpau62
Gsup LEVEL 3
Messages : 91
Enregistré le : ven. 15 sept. 2017 15:14

Re: Problème envoie de mail sondage

Message par dumpau62 » mar. 4 déc. 2018 11:04

Quelqu'un sur ce sujet ?
GestSup: 3.1.35 | Ubuntu: 18.04.1 LTS| MySQL: 5.7.24 | PHP: 7.2.10

Avatar du membre
Flox
Administrateur du site
Messages : 3619
Enregistré le : jeu. 21 juin 2012 19:00

Re: Problème envoie de mail sondage

Message par Flox » mar. 4 déc. 2018 11:58

Bonjour,

je ne reproduit pas le problème de mon côté en version 3.1.35 et 3.1.36 :
2018-12-04 11_15_32-screenshot-zensoft.png
2018-12-04 11_15_32-screenshot-zensoft.png (2.4 Kio) Vu 50 fois
est il possible d'avoir un impression écran des paramètres de mail automatique ainsi que des paramètre de la fonction sondage.

Si vous pouvez activer temporairement le mode debug et relancer une demande de sondage afin de voir si un message d'erreur apparaît.

Cdt
GestSup: 3.1.36 | Debian: 9.6 | Apache: 2.4.37 | MariaDB: 10.3.11 | PHP: 7.3.0

Avatar du membre
dumpau62
Gsup LEVEL 3
Messages : 91
Enregistré le : ven. 15 sept. 2017 15:14

Re: Problème envoie de mail sondage

Message par dumpau62 » mer. 5 déc. 2018 09:40

Bonjour,

J'ai modifié toute la config en fait. Précisément, j'ai modifié le "survey.php" en mettant mon propre code et aussi "core/auto_mail.php", ligne 314 avec un message personnalisé.

Voici les captures d'écrans:

survey.php

Image


core/auto_mail.php

Image


Je reçois bien les mail de notification mais pas le sondage...

Cdlt
GestSup: 3.1.35 | Ubuntu: 18.04.1 LTS| MySQL: 5.7.24 | PHP: 7.2.10

Avatar du membre
dumpau62
Gsup LEVEL 3
Messages : 91
Enregistré le : ven. 15 sept. 2017 15:14

Re: Problème envoie de mail sondage

Message par dumpau62 » mer. 5 déc. 2018 10:39

Voici les paramètres de l'appli:

Image
GestSup: 3.1.35 | Ubuntu: 18.04.1 LTS| MySQL: 5.7.24 | PHP: 7.2.10

Répondre